For Sale

Nuarc Printing Lamp help

Post your questions, suggestions, ideas and advice to issues you have run into in your screen printing shop.

Moderator: Moderator Team

Nuarc Printing Lamp help

Postby runner68 » Tue Oct 25, 2011 7:50 am

I am working on an older Nuarc unit,PL-631 lamp unit for screen exposure. When initially powering up,the lamp will come on for a couple of minutes. This has a warm up feature which lasts around 3 minutes. I hear a relay click and the lamp goes off. The lamp shield stays open,even though the bulb is not glowing. This unit starts up on high intensity and then supposed to go to either med or low depending on which is selected.
I left unit on for a few minutes longer and then the bulb came on again for a couple of minutes again,and went off. The cooling fans are running as they should.
I have little to go on. I do have a wiring schematic.
Would appreciate any imput. I have replaced the capacitors since they were leaking bad. This unit had been in storage for a number of years prior. It was taken out of service for same issues. :?:
runner68
Just Browsing
Just Browsing
 
Posts: 1
Joined: Tue Oct 25, 2011 7:23 am

Re: Nuarc Printing Lamp help

Postby tpitman » Mon Dec 05, 2011 2:30 am

You might want to post this over at M&R's forum:
http://forums.mrprint.com/forum.php

They are the owner of NuArc and would likely be able to assist you if you're not getting any response here.
tpitman
Just Browsing
Just Browsing
 
Posts: 13
Joined: Sun Dec 04, 2011 5:20 am


Return to Problems & Issues

Who is online

Users browsing this forum: No registered users



info to advertise here